solve-2636254_960_720

ブログ 運営

ワードプレスでプラグインが互換性がありません。「contact Form7」古いバージョンで切り抜ける!

2021/03/22


 

ワードプレスで使い慣れたプラグイン(contact Form7)を新しく立ち上げたサイトで使おうとしたら「互換性がありません」と表示されていた。かまわず、インストールして「有効化」をクリックした。がしかし「エラー」で使えない・・・。

 

プラグイン更新しても、結局は設定のやり直しがすごく煩雑で手間。「どうしよう・・・」と困ったことのある方って多いと思います。今回はとりあえず、今のワードプレスの環境をキープしつつ、一時的にでもすぐ使いたい場合に有効な方法を紹介します。

「contact Form7」がこれで使えるようになりました!

まずは画像をみてください。新しいサイトを立ち上げたときに「お問い合わせ」フォームを必ずいれると思います。それを助けるプラグイン「contact Form7」。ものすごく簡単で便利ですよね。

 

キャプチャ

 

上記の赤丸のように「互換性がありません」と表示されました。もちろん、「強引にインスト」 → 「有効化」自体はやりましたが・・・、やはり上手くいきませんでした。

 

赤矢印のように「互換性がある」他のプラグインを使っても良いのですが、「設定を調べて・・・検証して・・・」という時間に余裕が無かったので・・・慣れ親しんだプラグインを気合で使う方法はないか試行錯誤しました。

 

soldier-917956_960_720

 


ということで、プラグインの概要の右のほうにある「詳細情報」というのをクリックする。すると、プラグインのバージョン、ワードプレスの必要なバージョンなどがかかれている下記の画面が表示されます。「必須バージョン」:4.9以上と書いてありますね~。なるほど、最低ラインのこのバージョンなら使えるのかと思いつつ。

 

2

 

ここで「WordPress.org プラグインページ」をクリックする。すると下記画像のように画面右のほうに、次のような詳細が乗っています。これは単に日本語だった説明が英語になっているだけですね。なのでadvanced View」というのをクリックしてください。

3

 

次の画面で一番下までスクロールすると「PREVIOUS VERSIONS」という欄があります。ここで「Development Version」というのをクリック。して「4.9バージョン」をダウンロード。

4

 

スクリーンショット 2019-01-07 10.26.48

 

バージョンはいくつかダウンロードしてみよう!?

ちなみに、私は「4.9」バージョンをダウンロードしてアップロードしましたがが何故かできませんでした^^;

 

laptop-3087585_960_720

 

がしかし、「4.8.1」をダウンロードして、手動で「プラグイン新規追加」→「プラグインアップロード」したら無事に「contact Form7」がいままで通りに使えるようになりました!

 

「何で?」と思いつつ、ダウンロードしてからプラグイン「contact Form7」の「設定」を開いてみると「4.8以降に対応しています」と記載されています。「ん?4.9以上じゃないの?」って思いましたが・・・^^;こんな感じです↓

 

99

 

「ワードプレス、プラグインの更新」って煩雑だし、すぐ不具合起きるのであまりやらないので「この情報の違い」は・・・正直、わからないです!すいません^^;

 

結果オーライではないですが、「4.8.1」で上手くいきました。今後、対策を考える必要はありますが、取り急ぎサイトを立ち上げたい、他のプラグインを検証するほどの時間ない時は良いかと思います。

 

「contact Form7が導入できない時の対策」のまとめ☆

それではこの記事をまとめていきますね。

 

1.WordPress.org プラグインページから古いバージョンを探す

2.必須バージョンの中で古いものをダウンロード(1~2つ検証必要)

3.他のプラグインも使えるようにしておきましょう。

 

この方法が使えるのは時間の問題と思いますので、余裕があるときに他のプラグインも使えるように、平行して検証することをお勧めします。

 

スポンサーリンク

-ブログ 運営